summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind@gmail.com>2018-10-17 12:57:08 +0100
committerCalum Lind <calumlind@gmail.com>2018-10-19 14:14:03 +0100
commitc1ddcf60120b230dccc2add5282d580c0df602a8 (patch)
tree716b1c4ac929b38cdfca6c3c268b46d5a6a75635 /setup.py
parent85bbdfe1438fcd56090790782914ee4fba3ded64 (diff)
downloaddeluge-c1ddcf60120b230dccc2add5282d580c0df602a8.tar.gz
deluge-c1ddcf60120b230dccc2add5282d580c0df602a8.tar.bz2
deluge-c1ddcf60120b230dccc2add5282d580c0df602a8.zip
[Packaging] Add install_requires to setup.py
- Add an install_requires list to allow dependencies to be automatically installed via setuptools or pip installation. - Needed a workaround for twisted service_identity install.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 40ade8b6b..8d37b678a 100755
--- a/setup.py
+++ b/setup.py
@@ -543,6 +543,24 @@ _package_data['deluge.ui.web'] = [
]
_package_data['deluge.ui.gtkui'] = ['glade/*.ui']
+setup_requires = ['setuptools', 'wheel']
+install_requires = [
+ 'twisted[tls]>=16.6',
+ # Add pyasn1 for setuptools workaround:
+ # https://github.com/pypa/setuptools/issues/1510
+ 'pyasn1',
+ 'pyopenssl',
+ 'pyxdg',
+ 'pillow',
+ 'mako',
+ 'chardet',
+ 'six',
+ 'setproctitle',
+ "pywin32; sys.platform == 'win32'",
+ "py2-ipaddress; sys.platform == 'win32'",
+ "certifi; sys.platform == 'win32'",
+ 'zope.interface',
+]
docs_require = ['sphinx', 'recommonmark', 'sphinx-rtd-theme']
tests_require = [
'coverage',
@@ -594,6 +612,8 @@ setup(
],
license='GPLv3',
cmdclass=cmdclass,
+ setup_requires=setup_requires,
+ install_requires=install_requires,
extras_require={
'docs': docs_require,
'tests': tests_require,