summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind@gmail.com>2018-10-17 12:56:36 +0100
committerCalum Lind <calumlind@gmail.com>2018-10-19 14:14:03 +0100
commit85bbdfe1438fcd56090790782914ee4fba3ded64 (patch)
tree76ed4e88008052f19d70f4856604f05dae4ece0b /setup.py
parent9f9827ca585381d5eaa4add9a529f2c6745c83e1 (diff)
downloaddeluge-85bbdfe1438fcd56090790782914ee4fba3ded64.tar.gz
deluge-85bbdfe1438fcd56090790782914ee4fba3ded64.tar.bz2
deluge-85bbdfe1438fcd56090790782914ee4fba3ded64.zip
[Packaging] Cleanup dependencies
- Tweaked the layout a bit with optional part of dependency description. - Updated descriptions to help understand dependency usage. - Made intltool and chardet packages optional. This will help with installation where these might be missing and are not crucial. - Remove gettext from dependency as is part of Python.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d5fe90933..40ade8b6b 100755
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,7 @@ from distutils import cmd
from distutils.command.build import build as _build
from distutils.command.clean import clean as _clean
from distutils.command.install_data import install_data as _install_data
+from distutils.spawn import find_executable
from shutil import rmtree
from setuptools import find_packages, setup
@@ -206,8 +207,8 @@ class BuildTranslations(cmd.Command):
else:
basedir = os.path.join(self.build_lib, 'deluge', 'i18n')
- if not windows_check():
- intltool_merge = 'intltool-merge'
+ intltool_merge = 'intltool-merge'
+ if not windows_check() and find_executable(intltool_merge):
intltool_merge_opts = '--utf8 --quiet'
for data_file in (desktop_data, appdata_data):
# creates the translated file from .in file.