summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind@gmail.com>2018-06-01 15:35:19 +0100
committerCalum Lind <calumlind@gmail.com>2018-06-01 23:41:17 +0100
commitd642fa398924913c04eea3c2ddb769a4a6857fc3 (patch)
tree420c6e4d20b5550d1fc2ac2586968df4bf407ac6 /setup.py
parentbae1647e99e68244607e50633ca67a8c5b16ebfb (diff)
downloaddeluge-d642fa398924913c04eea3c2ddb769a4a6857fc3.tar.gz
deluge-d642fa398924913c04eea3c2ddb769a4a6857fc3.tar.bz2
deluge-d642fa398924913c04eea3c2ddb769a4a6857fc3.zip
Fix files to pass new Flake8 checkers
Some new flake8 checkers were added so fix these new warnings and any issues uncovered. Use add-trailing-comma to fix missing trailing commas. It does not format it as well as I would like however it was fast to change and helps with git changes in future. Removed pylint from tox due to large number of warnings.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6008dfd31..6fbe198ec 100755
--- a/setup.py
+++ b/setup.py
@@ -171,7 +171,7 @@ class BuildTranslations(cmd.Command):
user_options = [
('build-lib', None, 'lib build folder'),
- ('develop', 'D', 'Compile translations in develop mode (deluge/i18n)')
+ ('develop', 'D', 'Compile translations in develop mode (deluge/i18n)'),
]
boolean_options = ['develop']
@@ -258,7 +258,7 @@ class BuildPlugins(cmd.Command):
user_options = [
('install-dir=', None, 'develop install folder'),
- ('develop', 'D', 'Compile plugins in develop mode')
+ ('develop', 'D', 'Compile plugins in develop mode'),
]
boolean_options = ['develop']
@@ -353,7 +353,7 @@ class Build(_build):
sub_commands = [
('build_webui', None),
('build_trans', None),
- ('build_plugins', None)
+ ('build_plugins', None),
] + _build.sub_commands
def run(self):
@@ -372,7 +372,7 @@ class InstallData(_install_data):
def finalize_options(self):
self.install_dir = None
self.set_undefined_options('install', ('install_data', 'install_dir'),
- ('root', 'root'), ('force', 'force'),)
+ ('root', 'root'), ('force', 'force'))
def run(self):
_install_data.run(self)
@@ -548,5 +548,5 @@ setup(
exclude_package_data=_exclude_package_data,
packages=find_packages(exclude=['deluge.plugins.*', 'deluge.tests']),
namespace_packages=['deluge', 'deluge.plugins'],
- entry_points=_entry_points
+ entry_points=_entry_points,
)