summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Resch <andrewresch@gmail.com>2009-08-11 23:05:13 +0000
committerAndrew Resch <andrewresch@gmail.com>2009-08-11 23:05:13 +0000
commitc0d0498f36c9c053856f885d20bd6a8323817ba6 (patch)
treecd7bf218ab842e334a7efb918a3b57c22f0de951 /setup.py
parentba909ebcc9fb2f046ced3df325a79dab4700b62e (diff)
downloaddeluge-c0d0498f36c9c053856f885d20bd6a8323817ba6.tar.gz
deluge-c0d0498f36c9c053856f885d20bd6a8323817ba6.tar.bz2
deluge-c0d0498f36c9c053856f885d20bd6a8323817ba6.zip
Add rst files for all the modules
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 72f224163..60cc66ae9 100644
--- a/setup.py
+++ b/setup.py
@@ -296,8 +296,9 @@ class build_docs(BuildDoc):
return old_import(name, globals, locals, fromlist, level)
except ImportError:
return FakeModule()
- except:
- raise
+ except Exception, e:
+ print "Skipping Exception: ", e
+ return FakeModule()
__builtins__.__import__ = new_import
BuildDoc.run(self)