summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Garland <johnnyg@gmail.com>2010-01-24 02:23:57 +0000
committerJohn Garland <johnnyg@gmail.com>2010-01-24 02:23:57 +0000
commitb4b95c942376c06764127fc21ae450b51cfc8b5c (patch)
tree1456ff4509ba59b6c2f1e9de5da50b8ce44d9492 /setup.py
parente79f6ada2fdaa4d33108c272d817897afcbb8862 (diff)
downloaddeluge-b4b95c942376c06764127fc21ae450b51cfc8b5c.tar.gz
deluge-b4b95c942376c06764127fc21ae450b51cfc8b5c.tar.bz2
deluge-b4b95c942376c06764127fc21ae450b51cfc8b5c.zip
Don't opitimise when doing a debug build.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e6cb253b8..046faf7fc 100644
--- a/setup.py
+++ b/setup.py
@@ -334,7 +334,7 @@ class build_ext_debug(_build_ext):
lt_ext.extra_compile_args.remove('-DNDEBUG')
lt_ext.extra_compile_args.remove('-O2')
lt_ext.extra_compile_args.append('-g')
- remove_from_cflags(["-DNDEBUG"])
+ remove_from_cflags(["-DNDEBUG", "-O2"])
return _build_ext.run(self)
class clean_plugins(cmd.Command):