summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind+deluge@gmail.com>2019-05-21 15:48:43 +0100
committerCalum Lind <calumlind+deluge@gmail.com>2019-05-22 11:15:32 +0100
commita8fac1381b88c82cdc85059674e256aab033c36f (patch)
tree63787712b534de015722729e401485458274554d /setup.py
parent65f6ede8b24ad093285a514360a1082cec892f49 (diff)
downloaddeluge-a8fac1381b88c82cdc85059674e256aab033c36f.tar.gz
deluge-a8fac1381b88c82cdc85059674e256aab033c36f.tar.bz2
deluge-a8fac1381b88c82cdc85059674e256aab033c36f.zip
[Packaging] Cleanup README for Pypi
- Set a minimal Python version 3.5 and remove universal wheels. - Tidy up the README - Add Project URL for issues and docs.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 12b85f6f5..f36da2e97 100755
--- a/setup.py
+++ b/setup.py
@@ -567,6 +567,13 @@ setup(
long_description=open('README.md').read(),
long_description_content_type='text/markdown',
url='https://deluge-torrent.org',
+ project_urls={
+ 'GitHub (mirror)': 'https://github.com/deluge-torrent/deluge',
+ 'Sourcecode': 'http://git.deluge-torrent.org/deluge',
+ 'Issues': 'https://dev.deluge-torrent.org/report/1',
+ 'Discussion': 'https://forum.deluge-torrent.org',
+ 'Documentation': 'https://deluge.readthedocs.io',
+ },
classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',
@@ -584,6 +591,7 @@ setup(
'Operating System :: POSIX',
'Topic :: Internet',
],
+ python_requires='>=3.5',
license='GPLv3+',
cmdclass=cmdclass,
setup_requires=setup_requires,