summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind@gmail.com>2018-10-05 15:24:36 +0100
committerCalum Lind <calumlind@gmail.com>2018-10-05 18:45:37 +0100
commita8a4fb69c099b82f3d35ac94e6198996971749dc (patch)
tree03ccc1f594bcf2cdffe9f93bfd4912d4a99b7361 /setup.py
parent6cf13d112bd619c487d8ef50f6854b94a0cb86bd (diff)
downloaddeluge-a8a4fb69c099b82f3d35ac94e6198996971749dc.tar.gz
deluge-a8a4fb69c099b82f3d35ac94e6198996971749dc.tar.bz2
deluge-a8a4fb69c099b82f3d35ac94e6198996971749dc.zip
[Lint] Exclude js and css from EOF fixer
- When running pre-commit on all files it is picking up minified js and css files. Since prettier will format correctly the source files ignore them in end-of-file fixer. - The template files in web docs can be ignored too. - Removed the unneeded `pre-commit-hooks` dependency as pre-commit resolves that itself. - Include files fixed by pre-commit.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 13282f4ee..d9c7ae3f5 100755
--- a/setup.py
+++ b/setup.py
@@ -549,7 +549,6 @@ tests_require = [
'flake8-mutable',
'flake8-quotes',
'pre-commit',
- 'pre-commit-hooks',
'pytest',
'detox',
'tox',