summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind+deluge@gmail.com>2016-11-28 12:57:07 +0000
committerCalum Lind <calumlind+deluge@gmail.com>2016-11-28 13:00:09 +0000
commit3cbafec68d580d2c8f4faa5f69e8cb635ef82542 (patch)
tree3ea2fb055d7d518e777130cb5f95c79904b5ea41 /setup.py
parenta48c01c3a55b84a43f768e4dd82836209539729b (diff)
downloaddeluge-3cbafec68d580d2c8f4faa5f69e8cb635ef82542.tar.gz
deluge-3cbafec68d580d2c8f4faa5f69e8cb635ef82542.tar.bz2
deluge-3cbafec68d580d2c8f4faa5f69e8cb635ef82542.zip
[Setup] Move deluge egg-info clean to Clean
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index a98b2cb29..7ae0716cb 100755
--- a/setup.py
+++ b/setup.py
@@ -313,19 +313,19 @@ class CleanPlugins(cmd.Command):
os.remove(os.path.join(path, fpath))
os.removedirs(path)
- root_egg_info_dir_path = 'deluge*.egg-info'
+class Clean(_clean):
+ sub_commands = _clean.sub_commands + [('clean_plugins', None)]
+
+ def run(self):
+ # Remove deluge egg-info.
+ root_egg_info_dir_path = 'deluge*.egg-info'
for path in glob.glob(root_egg_info_dir_path):
print('Deleting %s' % path)
for fpath in os.listdir(path):
os.remove(os.path.join(path, fpath))
os.removedirs(path)
-
-class Clean(_clean):
- sub_commands = _clean.sub_commands + [('clean_plugins', None)]
-
- def run(self):
# Run all sub-commands (at least those that need to be run)
for cmd_name in self.get_sub_commands():
self.run_command(cmd_name)