summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCalum Lind <calumlind@gmail.com>2018-11-11 14:56:49 +0000
committerCalum Lind <calumlind@gmail.com>2018-11-12 10:10:41 +0000
commit3b8f71613b65a1f23c5b5429b17daa8241cb032a (patch)
treec9fec3d3fadb9c48dfed1406ef2dcc33478b0ea7 /setup.py
parent10fcbecc0413733f50590890fb54d4b3fd710d13 (diff)
downloaddeluge-3b8f71613b65a1f23c5b5429b17daa8241cb032a.tar.gz
deluge-3b8f71613b65a1f23c5b5429b17daa8241cb032a.tar.bz2
deluge-3b8f71613b65a1f23c5b5429b17daa8241cb032a.zip
[Packaging] Fix deps for win32
- Fixed trying to install py2-ipaddress breaking on Python3. - Add wheel universal option so Py2 and Py3 wheel built.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7d1183da2..9ff305ef4 100755
--- a/setup.py
+++ b/setup.py
@@ -547,9 +547,9 @@ install_requires = [
'chardet',
'six',
'setproctitle',
- "pywin32; sys.platform == 'win32'",
- "py2-ipaddress; sys.platform == 'win32'",
- "certifi; sys.platform == 'win32'",
+ "pywin32; sys_platform == 'win32'",
+ "py2-ipaddress; sys_platform == 'win32' and python_version == '2'",
+ "certifi; sys_platform == 'win32'",
'zope.interface',
]
tests_require = ['pytest', 'pytest-twisted']