summaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorCalum Lind <calumlind@gmail.com>2018-10-02 15:39:51 +0100
committerCalum Lind <calumlind@gmail.com>2018-10-03 15:21:53 +0100
commitb1cdc32f7357e9777eb6cc2d90094c7d122af2eb (patch)
tree9106ac399a7df178c8dbed6fe58009d36b18159a /setup.cfg
parentbcca07443ccad7f130444baaac52b7b49478905e (diff)
downloaddeluge-b1cdc32f7357e9777eb6cc2d90094c7d122af2eb.tar.gz
deluge-b1cdc32f7357e9777eb6cc2d90094c7d122af2eb.tar.bz2
deluge-b1cdc32f7357e9777eb6cc2d90094c7d122af2eb.zip
[Lint] Use Black to auto-format code
The move to using auto-formatter makes it easier to read, submit and speeds up development time. https://github.com/ambv/black/ Although I would prefer 79 chars, the default line length of 88 chars used by black suffices. The flake8 line length remains at 120 chars since black does not touch comments or docstrings and this will require another round of fixes. The only black setting that is not standard is the use of double-quotes for strings so disabled any formatting of these. Note however that flake8 will still flag usage of double-quotes. I may change my mind on double vs single quotes but for now leave them. A new pyproject.toml file has been created for black configuration.
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg23
1 files changed, 22 insertions, 1 deletions
diff --git a/setup.cfg b/setup.cfg
index 9fee85746..8d62dd2a6 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -25,5 +25,26 @@ known_third_party =
pygtk, gtk, gobject, gtk.gdk, pango, cairo, pangocairo
known_first_party = msgfmt, deluge
order_by_type = true
-line_length = 120
not_skip = __init__.py
+# Black compatible settings
+multi_line_output=3
+include_trailing_comma=True
+force_grid_wrap=0
+line_length=88
+use_parentheses=True
+
+[flake8]
+max-line-length = 120
+builtins = _,_n,__request__
+exclude = .git,.tox,dist,build
+ignore =
+# A003 Class attribute is a python builtin.
+ A003,
+# C813, C815, C816: PY3 missing trailing commas.
+ C813,C815,C816,
+# W503 line break before binary operator.
+ W503,
+ E203
+
+[pycodestyle]
+max-line-length = 88