summaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorCalum Lind <calumlind+deluge@gmail.com>2021-01-17 15:48:35 +0000
committerCalum Lind <calumlind+deluge@gmail.com>2021-01-24 20:40:20 +0000
commit610a1bb3139f8ded69561b290d7ce61b5a039676 (patch)
tree4e18e880de320e248e0f079adab74fe1c67157f8 /setup.cfg
parent23a48dd01c86ef01cd1d13371de51247ec9a503b (diff)
downloaddeluge-610a1bb3139f8ded69561b290d7ce61b5a039676.tar.gz
deluge-610a1bb3139f8ded69561b290d7ce61b5a039676.tar.bz2
deluge-610a1bb3139f8ded69561b290d7ce61b5a039676.zip
[Lint] Update pre-commit hook and isort versions
* Fixed black hook requiring Py3.6 to installed locally. Will now assume Py3.6+ in installed. * Added isort traceback in pre-commit flake8 hook fails * Updated versions of Black, Prettier and isort * Keep Flake8 at 3.7.9 due to E402 issue: https://gitlab.com/pycqa/flake8/-/issues/638 * New pyproject config for isort v5 with fixes for Python 2 imports. * Fixed travis config to run Python 3.6 for lint run. Replaced the virtualenv with_system_site_packages config with Travis specific Python config value so lint run doesn't attempt to append with_system_site_packages to Python 3.6 command.
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg18
1 files changed, 0 insertions, 18 deletions
diff --git a/setup.cfg b/setup.cfg
index e52fa07cd..b4071f53e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -24,24 +24,6 @@ includes = glib, gio, cairo, pango, pangocairo, atk, gobject, gtk.keysyms,
HTMLParser
frameworks = CoreFoundation, Foundation, AppKit
-[isort]
-known_standard_library = future_builtins
-known_third_party =
-# Ignore gtk modules, primarily for tox testing.
- cairo, gi,
-# Ignore other module dependencies for pre-commit isort.
- twisted, OpenSSL, pytest, recommonmark, chardet, pkg_resources, zope, mock,
- sphinx, rencode, six, mako
-known_first_party = msgfmt, deluge
-order_by_type = true
-not_skip = __init__.py
-# Black compatible settings
-multi_line_output=3
-include_trailing_comma=True
-force_grid_wrap=0
-line_length=88
-use_parentheses=True
-
[flake8]
max-line-length = 120
builtins = _,_n,__request__