summaryrefslogtreecommitdiffstats
path: root/CHANGELOG.md
Commit message (Collapse)AuthorAge
* Release 2.1.1Calum Lind2022-07-10
|
* [Docs] Update changelog and install detailsCalum Lind2022-07-08
|
* back to developmentdeluge-2.1.1.dev0Calum Lind2022-06-28
|
* Release 2.1.0Calum Lind2022-06-28
|
* Update Changelog entriesCalum Lind2022-06-19
|
* Remove all Python 2 supportdeluge-2.1.0.dev0DjLegolas2021-12-28
| | | | | | | | | * Removed all __future__ imports from code * Removed all six dependencies * Removed all future_builtins imports * Removed all Python 2 related code Closes: deluge-torrent/deluge#325
* back to developmentCalum Lind2021-12-15
|
* Release 2.0.5deluge-2.0.52.0.xCalum Lind2021-12-15
|
* Update ChangelogCalum Lind2021-12-15
|
* back to developmentCalum Lind2021-12-12
|
* Release 2.0.4deluge-2.0.4Calum Lind2021-12-12
|
* Update changelogCalum Lind2021-12-12
|
* [WebUI] Handle torrent add failuresDjLegolas2019-06-21
| | | | Closes #2253.
* [Docs] Add service how-tosCalum Lind2019-06-18
|
* [Docs] Add spellchecking with pyenchantCalum Lind2019-06-15
| | | | | | | | | - Use sphinxcontrib.spelling with custom wordlist. - Skip the checking of the modules documents as they raise false-positives. - Add a setup.py spellcheck_docs command. - Fix spelling and other issues. - Add a doc favicon.
* Release 2.0.3deluge-2.0.3Calum Lind2019-06-12
|
* [GTK] Only import wnck on X11 displayCalum Lind2019-06-12
| | | | | | | Wnck is only supported on X11 and raises errors in Wayland so only load it when X11 present. Fixes: #3265
* [GTK] Fix peers tab flag tooltip errorCalum Lind2019-06-12
| | | | | | | | | Hovering over a country flag resulted in an AttributeError. This is due to get_tooltip_context now returning a bool value instead of the tooltip object. Fixes: #3219
* [Extractor] Fix startup errorCalum Lind2019-06-12
| | | | | | On Python 3 need to create a copy of the dict to iterate Fixes: #3264
* [Web] Fix unable to change passwordCalum Lind2019-06-11
| | | | | | | | | The hashlib update method requires bytes and raised a TypeError for salt passed as text. Added a test for auth change_password Fixes: #3262
* [Web] Change request.base path encoding to utf-8Calum Lind2019-06-11
| | | | | | | | | | | A user reported a problem with setting base path resulting in this error: encoding with 'idna' codec failed (UnicodeError: label too long) It is likely the base path is longer than 63 chars, which is unusual, however the idna codec is for domain name not paths so switch to utf-8. Fixes: #3261
* [Web] Fix TypeError with reverse proxy x-deluge-base headerCalum Lind2019-06-11
| | | | | | The request header needs decoded otherwise string comparisons fail. Fixes: #3260
* [Docs] Remove incomplete Windows install instructionsCalum Lind2019-06-11
| | | | | The instructions are in-progress and missing steps so instead point to the issue ticket for now.
* [Web] Fix peers tab failing to set flag locationthelamer2019-06-11
| | | | The request.country returns bytes not a string so decode.
* Make a 2.0.2 releasedeluge-2.0.2Calum Lind2019-06-08
|
* [Packaging] Move user out of systemd files and add to tarballCalum Lind2019-06-08
| | | | | | | | | | | | | | | With the `deluge` user specified in the unit files it ties it to that user and makes it unavailable for re-use by systemd user instance. Remove the user and group from the unit files and put them in a separate `user.conf` file that should be installed as an override file e.g. for deluged.service this would be placed as follows: /etc/systemd/service/deluge.service.d/user.conf Add the systemd files to the tarball for package maintainers. Closes: #2034
* [Core] Fix SimpleNamespace on Python2Calum Lind2019-06-08
|
* Update Changelog for 2.0.1deluge-2.0.1Calum Lind2019-06-07
|
* Back to devCalum Lind2019-06-06
|
* Updates for 2.0.0 releasedeluge-2.0.0Calum Lind2019-06-06
|
* [Docs] Cleanup changelog and docsCalum Lind2019-06-06
|
* Cleanup and use markdown for source text filesCalum Lind2018-10-16
Use markdown to aid readability. Update the README and use it for the long_description in setup.py Add detailed requirement information to the DEPENDS files.