summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7d1183da2..9ff305ef4 100755
--- a/setup.py
+++ b/setup.py
@@ -547,9 +547,9 @@ install_requires = [
'chardet',
'six',
'setproctitle',
- "pywin32; sys.platform == 'win32'",
- "py2-ipaddress; sys.platform == 'win32'",
- "certifi; sys.platform == 'win32'",
+ "pywin32; sys_platform == 'win32'",
+ "py2-ipaddress; sys_platform == 'win32' and python_version == '2'",
+ "certifi; sys_platform == 'win32'",
'zope.interface',
]
tests_require = ['pytest', 'pytest-twisted']