summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Resch <andrewresch@gmail.com>2008-10-23 08:13:08 +0000
committerAndrew Resch <andrewresch@gmail.com>2008-10-23 08:13:08 +0000
commitff6906997b64d7bb89712f34f8c7e581bb7e3889 (patch)
tree5612ccc23d05024d09704834c18e3933945ee0e3 /setup.py
parent718c789c8ede356f5c2f8d6f1c53f1d588bbfccb (diff)
downloaddeluge-ff6906997b64d7bb89712f34f8c7e581bb7e3889.tar.gz
deluge-ff6906997b64d7bb89712f34f8c7e581bb7e3889.tar.bz2
deluge-ff6906997b64d7bb89712f34f8c7e581bb7e3889.zip
Windows build system fixes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 18 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 7957918a9..6bb46feb5 100644
--- a/setup.py
+++ b/setup.py
@@ -179,22 +179,23 @@ else:
'z'
]
- dynamic_lib_extension = ".so"
- if osx_check():
- dynamic_lib_extension = ".dylib"
-
- _lib_extensions = ['-mt-1_36', '-mt-1_35', '-mt']
-
- # Modify the libs if necessary for systems with only -mt boost libs
- for lib in _libraries:
- if lib[:6] == "boost_":
- for lib_prefix in _library_dirs:
- for lib_suffix in _lib_extensions:
- # If there is a -mt version use that
- if os.path.exists(os.path.join(lib_prefix, "lib" + lib + lib_suffix + dynamic_lib_extension)):
- _libraries[_libraries.index(lib)] = lib + lib_suffix
- lib = lib + lib_suffix
- break
+ if not windows_check():
+ dynamic_lib_extension = ".so"
+ if osx_check():
+ dynamic_lib_extension = ".dylib"
+
+ _lib_extensions = ['-mt-1_36', '-mt-1_35', '-mt']
+
+ # Modify the libs if necessary for systems with only -mt boost libs
+ for lib in _libraries:
+ if lib[:6] == "boost_":
+ for lib_prefix in _library_dirs:
+ for lib_suffix in _lib_extensions:
+ # If there is a -mt version use that
+ if os.path.exists(os.path.join(lib_prefix, "lib" + lib + lib_suffix + dynamic_lib_extension)):
+ _libraries[_libraries.index(lib)] = lib + lib_suffix
+ lib = lib + lib_suffix
+ break
_sources = glob.glob("./libtorrent/src/*.cpp") + \
glob.glob("./libtorrent/src/*.c") + \
@@ -211,7 +212,7 @@ for source in _sources:
break
_ext_modules = []
-if not os.path.exists(os.path.join(sysconfig.get_config_var("LIBDIR"), "libtorrent-rasterbar.so.1")):
+if windows_check() or not os.path.exists(os.path.join(sysconfig.get_config_var("LIBDIR"), "libtorrent-rasterbar.so.1")):
# There isn't a system libtorrent library, so let's build the one included with deluge
libtorrent = Extension(
'libtorrent',