summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Resch <andrewresch@gmail.com>2008-11-29 20:48:37 +0000
committerAndrew Resch <andrewresch@gmail.com>2008-11-29 20:48:37 +0000
commit6bd1682728d68a3736cf2c8940b7ab95bf53e25e (patch)
tree2049004ebc0007aa6e646a0ce686c0cbef759a48 /setup.py
parentbb8c41ad0371c44d17fbfd3076be861751d4014b (diff)
downloaddeluge-6bd1682728d68a3736cf2c8940b7ab95bf53e25e.tar.gz
deluge-6bd1682728d68a3736cf2c8940b7ab95bf53e25e.tar.bz2
deluge-6bd1682728d68a3736cf2c8940b7ab95bf53e25e.zip
Fix building on FreeBSD
Add some more metadata
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 10 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8fd79b85e..0d7d7a573 100644
--- a/setup.py
+++ b/setup.py
@@ -122,7 +122,10 @@ if windows_check():
'zlib'
]
else:
- _include_dirs += ['/usr/include/python' + python_version]
+ _include_dirs += [
+ '/usr/include/python' + python_version,
+ sysconfig.get_config_var("INCLUDEDIR")
+ ]
_library_dirs += [sysconfig.get_config_var("LIBDIR"), '/opt/local/lib']
if osx_check():
_include_dirs += [
@@ -320,11 +323,15 @@ _data_files = [
# Main setup
setup(
author = "Andrew Resch, Marcos Pinto, Martijn Voncken, Sadrul Habib Chowdhury",
- author_email = "andrewresch@gmail.com, markybob@dipconsultants.com, \
- mvoncken@gmail.com, sadrul@users.sourceforge.net",
+ author_email = "andrewresch@gmail.com, markybob@dipconsultants.com, mvoncken@gmail.com, sadrul@users.sourceforge.net",
cmdclass = cmdclass,
data_files = _data_files,
description = "Bittorrent Client",
+ long_description = """Deluge is a bittorrent client that utilizes a
+ daemon/client model. There are various user interfaces available for
+ Deluge such as the GTKui, the webui and a console ui. Deluge uses
+ libtorrent in it's backend to handle the bittorrent protocol.""",
+ keywords = "torrent bittorrent p2p fileshare filesharing",
entry_points = """
[console_scripts]
deluge = deluge.main:start_ui