summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Resch <andrewresch@gmail.com>2009-02-23 11:25:07 +0000
committerAndrew Resch <andrewresch@gmail.com>2009-02-23 11:25:07 +0000
commit45a6e423564d79e434875522faab9567f1b6f468 (patch)
treed22861d49e46d31879f270525509edb888829628 /setup.py
parentd0c369fb5846a7cb8b45e857b71077db27cc867a (diff)
downloaddeluge-45a6e423564d79e434875522faab9567f1b6f468.tar.gz
deluge-45a6e423564d79e434875522faab9567f1b6f468.tar.bz2
deluge-45a6e423564d79e434875522faab9567f1b6f468.zip
Fix building plugins when python isn't in the PATH
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 39a2db46f..89d334637 100644
--- a/setup.py
+++ b/setup.py
@@ -23,6 +23,7 @@
import ez_setup
ez_setup.use_setuptools()
import glob
+import sys
from setuptools import setup, find_packages, Extension
from distutils import cmd, sysconfig
@@ -258,12 +259,10 @@ class build_plugins(cmd.Command):
def run(self):
# Build the plugin eggs
PLUGIN_PATH = "deluge/plugins/*"
- if windows_check():
- PLUGIN_PATH = "deluge\\plugins\\"
for path in glob.glob(PLUGIN_PATH):
if os.path.exists(os.path.join(path, "setup.py")):
- os.system("cd " + path + "&& python setup.py bdist_egg -d ..")
+ os.system("cd " + path + "&& " + sys.executable + " setup.py bdist_egg -d ..")
class build(_build):
sub_commands = [('build_trans', None), ('build_plugins', None)] + _build.sub_commands
@@ -288,12 +287,10 @@ class clean_plugins(cmd.Command):
print("Cleaning the plugin folders..")
PLUGIN_PATH = "deluge/plugins/*"
- if windows_check():
- PLUGIN_PATH = "deluge\\plugins\\"
for path in glob.glob(PLUGIN_PATH):
if os.path.exists(os.path.join(path, "setup.py")):
- c = "cd " + path + "&& python setup.py clean"
+ c = "cd " + path + "&& "+ sys.executable + " setup.py clean"
if self.all:
c += " -a"
os.system(c)